GeForce NOW powered by CloudGG - AU East 1 Service Disruption – Incident details

AU East 1 Service Disruption

Resolved
Degraded performance
Started 2 months agoLasted about 9 hours

Affected

GeForce NOW Zones

Degraded performance from 5:30 AM to 2:51 PM

AU-East1

Degraded performance from 5:30 AM to 2:51 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

    If you continue to see errors, please report these using the in-app feedback feature.

  • Monitoring
    Monitoring

    NVIDIA have identified an issue, implemented a fix and are currently monitoring the result.

  • Investigating
    Investigating

    We are investigating reports of Casual members using AU East 1 (SYD-01) encountering the following errors:

    • Game is not supported in your region

    • GeForce NOW is at capacity

    If you are encountering an issue please report it in the GeForce NOW client feedback module (found to the right of the search bar).

    After reporting the issue, please try exiting your GeForce NOW app or browser, then try again.