GeForce NOW powered by CloudGG - Service Disruption – Incident details

Service Disruption

Resolved
Operational
Started 17 days agoLasted about 2 hours

Affected

GeForce NOW Zones

Degraded performance from 10:59 PM to 1:23 AM

AU-East1

Degraded performance from 10:59 PM to 1:23 AM

AU-East2

Degraded performance from 10:59 PM to 1:23 AM

AU-West1

Degraded performance from 10:59 PM to 1:23 AM

Updates
  • Resolved
    Resolved

    This issue was resolved.

    Please contact support if you continue to encounter an issue.

  • Investigating
    Investigating

    We are investigating reports of various errors including:

    • Zone in maintenance
    • Zone at capacity
    • Not available in your region
    • Titles patching

    Please reach out to our support team (including screenshots) if you are encountering an issue starting a session.