GeForce NOW powered by CloudGG - Service Disruption Causing Queues – Incident details

Service Disruption Causing Queues

Resolved
Degraded performance
Started about 1 month agoLasted about 4 hours

Affected

GeForce NOW Zones

Degraded performance from 2:00 AM to 5:51 AM

AU-East1

Degraded performance from 2:00 AM to 5:51 AM

AU-East2

Degraded performance from 2:00 AM to 5:51 AM

AU-West1

Degraded performance from 2:00 AM to 5:51 AM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

    If you continue to encounter an issue please contact support via the CloudGG Portal or the CloudGG Community Forum.

  • Identified
    Identified

    We are working with NVIDIA to resolve a service issue affecting NVIDIA and GeForce NOW alliance services.

    You may experience queues until the issue has been fixed.

    You can also track NVIDIA's incident tracker at https://status.geforcenow.com/incidents/782lznzfsb57