GeForce NOW powered by CloudGG - Third-Party Service Disruption – Incident details

Third-Party Service Disruption

Resolved
Degraded performance
Started about 2 months agoLasted about 2 hours

Affected

GeForce NOW Zones

Major outage from 9:29 AM to 11:07 AM

AU-East1

Major outage from 9:29 AM to 11:07 AM

AU-East2

Major outage from 9:29 AM to 11:07 AM

AU-West1

Major outage from 9:29 AM to 11:07 AM

Updates
  • Resolved
    Resolved

    AWS has reported it has recovered.

    We will continue to monitor performance and feedback over the next several hours.

  • Identified
    Identified

    Some online multiplayer games such as Fortnite may not launch or present an error due to an Amazon Web Service (AWS) outage. Games using AWS for online features are affected.