GeForce NOW powered by CloudGG - Service Disruption – Incident details

Service Disruption

Resolved
Operational
Started 28 days agoLasted about 2 hours

Affected

GeForce NOW Zones

Major outage from 8:55 AM to 10:47 AM, Operational from 10:47 AM to 10:59 AM

AU-East2

Major outage from 8:55 AM to 10:47 AM, Operational from 10:47 AM to 10:59 AM

Updates
  • Resolved
    Resolved

    This issue is now resolved.

    We will continue to monitor the performance of AU East 2 overnight.

  • Monitoring
    Monitoring

    We implemented a fix and are currently monitoring the results.

    We are seeing activity in AU East 2 return to normal and queues have reduced.

  • Update
    Update

    We are working with NVIDIA to isolate the issue.

    We do not have an ETA on when services will return to normal, we are working to resolve the issue as soon as possible.

  • Investigating
    Investigating

    We are currently investigating a disruption affecting AU East 2.

    This affects our Performance and Ultimate members.

    You may not be able to start a new session, may experience a queue, or receive an error message when starting a new game session.