GeForce NOW powered by CloudGG - NVIDIA Service Disruption – Incident details

NVIDIA Service Disruption

Resolved
Operational
Started about 1 month agoLasted about 1 hour

Affected

GeForce NOW Zones

Partial outage from 4:00 AM to 5:02 AM, Degraded performance from 4:00 AM to 5:02 AM

AU-East1

Partial outage from 4:00 AM to 5:02 AM

AU-East2

Degraded performance from 4:00 AM to 5:02 AM

AU-West1

Partial outage from 4:00 AM to 5:02 AM

Updates
  • Resolved
    Resolved

    A fix has been implemented and we will continue to monitor results over the coming hours.

    If you encounter a technical issue with the client or a game please report the issue by either:

    1. Using the in-client feedback module. It is located next to your username in the top right of the client.

    2. Making a post on our community forum.

    3. Contact support in your CloudGG portal for further assistance.

  • Investigating
    Investigating

    We are aware of a global outage affecting some of NVIDIA's services, NVIDIA is currently investigating.

    You may experience unexpected behaviour when starting a session or playing a game.