GeForce NOW powered by CloudGG - Service Disruption – Incident details

Service Disruption

Resolved
Partial outage
Started 28 days agoLasted about 4 hours

Affected

GeForce NOW Zones

Partial outage from 10:00 PM to 2:10 AM

AU-East

Partial outage from 10:00 PM to 2:10 AM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

    If you continue to experience an issue please try signing out and back into your CloudGG account.

  • Identified
    Identified

    We are currently working with NVIDIA to resolve an issue resulting in:

    - Sessions being unable to launch.
    - The GeForce NOW client appearing blank.
    - Error codes 0x00000097 and 0x00000099.

    We do not currently have an ETA on a resolution.