GeForce NOW powered by CloudGG - Some sessions failing to start (C2720021, C192000C) – Incident details

Some sessions failing to start (C2720021, C192000C)

Resolved
Partial outage 0
Started about 2 months agoLasted about 7 hours

Affected

GeForce NOW Zones

Partial outage from 1:49 AM to 8:50 AM

AU-East1

Partial outage from 1:49 AM to 8:50 AM

AU-East2

Partial outage from 1:49 AM to 8:50 AM

Updates
  • Resolved
    Resolved

    This incident has been resolved. We are continuing to monitor reports of error messages and game crashes

  • Identified
    Identified

    We're aware of some sessions in AU-East1 and AU-East2 zones failing to start with error codes C2720021 and C192000C.

    This global incident is under active investigation by NVIDIA. For further updates, please check NVIDIA's official GeForce NOW status page at https://status.geforcenow.com.