Software Updates for East 2 and West 1
Scheduled for October 21, 2024 at 1:00 PM – October 22, 2024 at 1:00 PM
Affects
GeForce NOW Zones
Under maintenance from 1:00 PM to 1:00 PM
AU-East2
Under maintenance from 1:00 PM to 1:00 PM
AU-West1
Under maintenance from 1:00 PM to 1:00 PM
Completed
October 22, 2024 at 1:00 PMCompleted
October 22, 2024 at 1:00 PMMaintenance has completed successfully
In progress
October 21, 2024 at 1:00 PMIn progress
October 21, 2024 at 1:00 PMMaintenance is now in progress
Planned
October 21, 2024 at 1:00 PMPlanned
October 21, 2024 at 1:00 PMWe are performing scheduled maintenance on East 2 and West 1.
Users on West and Ultimate members on East 2 may encounter higher than usual waiting times.
While we do not require downtime for this maintenance period, we will be updating software on machines that are idle.